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C H A P T E R  1 2

Managing Your Files

Files are what make the world of Linux go round. They’re the currency of any kind of 

operating system, because every time you use your computer, you generate new files, 

even if they’re only temporary.

How Linux views files, as well as the disks and partitions that contain them, varies some-

what from how Windows handles files. In many ways, the Linux system of file management 

is far simpler than that in Windows (which, ironically, was created as an attempt to make 

everything easy!).

In this chapter, we will explain how you can manage your files under Ubuntu. This isn’t 

a definitive guide; you’ll need to wait until Chapter 14 to learn the technical ins and outs 

of the file system and the all-important system of user accounts that goes hand-in-hand 

with files. However, this chapter provides enough information for you to understand how 

the system works, and where and how you should store your data.

Understanding File System Concepts
Just like Windows, Ubuntu has a file system that is shared among software components 

and your own personal data, which you generate within various applications, or perhaps 

download from the Internet. However, Ubuntu differs from Windows in a couple of 

important ways.

Drive References

Perhaps the most important differences between Linux and Windows are the following:

• The Linux file system doesn’t use drive letters.

• The Linux file system uses a forward slash (/) instead of a backslash (\) in filename 

paths. 
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In other words, something like /home/john/myfile is typical under Ubuntu, as opposed 

to C:\Documents and Settings\John\myfile under Windows. The root of the hard disk 

partition is usually referred to as C:\ under Windows. In Ubuntu, it’s referred to simply 

with a forward slash (/). 

If you have more than one drive, the drives are usually combined into one file system 

under Linux. This is done by mounting, so that the any additional drives appear as virtual 

folders under the file system. In other words, you browse the other hard disks by switching 

to various directories within the main file system. We’ll explain mounting in Chapter 14.

■Note  If you’re used to Mac OS X, then the Ubuntu file system shouldn’t come as much of a surprise, 

because both OS X and Ubuntu are based on Unix and utilize similar concepts.

Names of Files

Another important difference between Ubuntu and Windows is that filenames in Ubuntu 

are case-sensitive. This means that MyFile is distinctly different from myfile. Uppercase 

letters are vitally important. In Windows, filenames might appear to have uppercase letters in 

them, but these actually are ignored when you rename or otherwise manipulate files.

Because of this case-sensitivity, you could have two separate files existing in the same 

place, one called MyFile and another called myfile. In fact, you could also have myFile, 

Myfile, MYFILE, and so on, as shown in Figure 12-1.

As with Windows, filenames can have spaces within them. This means it’s possible to 

have file or folder names like Pictures from Disneyland or party at bob's house.jpg. 

■Note  You might notice that some Linux old-hands avoid using spaces in filenames and use an underscore 

character (_) instead. There are two main reasons for this. The first is that it’s tricky to manipulate filenames 

with spaces in them at the command prompt (discussed in Part 4 of this book). Secondly, Internet services 

are often incompatible with filenames with spaces in them, which means that to use those services, you 

would need to rename files (unless you put them in an archive first). 

Unlike with Windows, filenames can include virtually any symbol, including an asterisk (*), 

backslash (\), question mark (?), less-than/greater-than signs (< and >), and so on. The 

only symbol that’s prohibited is the forward slash (/), and that’s because it has a special 

use in file paths, as described in the previous section. Be aware, however, that if you wish 

to share files with colleagues running Windows, you should stick to Windows conventions 

to avoid incompatibilities, and refrain from using the following symbols: \/:*?"<>|.
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Figure 12-1. Ubuntu filenames are case-sensitive, so many similar filenames can exist, 

differing only in which letters are capitalized.

■Note  If you try to copy a file with illegal symbols to a Windows machine across a network, Ubuntu simply 

won’t let you, and will report an Invalid Parameters error. 

File Access and Storage

Windows Vista tightens up security and does not allow users to write files outside the 

Users directory unless they have permission, But under Windows XP, you have access to 

the entire hard disk. You can write, read, or delete files anywhere (unless the system has 

specifically been configured otherwise). You can save your personal files in C:\Windows, 

for example. 

Under Ubuntu, ordinary users can browse most of the hard disk, but they aren’t able to 

write files to the majority of folders (in some cases, they won’t even be able to access files). 

Although we’ll cover the file system in much more depth in Chapter 14, for the moment, 

it’s enough to know that you’ve been given your own part of the hard disk in which to store 

your stuff. This is a directory located within the /home directory, and its name is taken from 

your username. If your login name is louisesmith, your place for storing files will be /home/

louisesmith. Figure 12-2 shows an example of a user’s home directory.
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■Note  Linux generally uses the terms directory and subdirectory for the places you put files, whereas 

Windows refers to them as folders. It’s merely a matter of semantics. However, within the Nautilus file 

browser, directories are pictured as folders and are referred to as such.

Figure 12-2. Your personal area on the hard disk is in the /home directory and is named after 

your username.

Some programs might create subdirectories in your home directory in order to store and 

organize their output. For example, a digital camera program might create a Pictures 

directory within your /home directory. It’s up to you whether you use these. The standard 

practice within the Linux community is to simply save everything into your /home subdi-

rectory (for example, /home/keir) and sort it out later! 

Files within Ubuntu remember who owns them. If user johnsmith creates a file, he can 

make it so that only he can read or write the file (the default setting is that other users will 

be able to read the file, but not write any new data to it). Directories, too, are owned by 
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people, and the owner can set access permissions. By default, all users on a system can 

access each other’s /home directories and read files, but they won’t be able to change the 

files or write new files to any directory within /home that isn’t theirs.

■Note  Any user with superuser powers has access to all of the system and can create, edit, and delete files 

in all directories. This is so the user can perform essential system maintenance. 

Using Nautilus
Nautilus is the name of the default file browser in Ubuntu. It’s similar to My Computer or 

Windows Explorer under Windows, in that it presents a list of files on the right side of the 

window and a series of shortcuts to popular locations within the file system on the left side.

Starting Nautilus is simply a matter of clicking the Places menu and choosing a loca-

tion, as shown in Figure 12-3. 

Figure 12-3. You can open a file browser window by selecting a location from the Places menu.
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The Nautilus window (see Figures 12-1, 12-2, and 12-4) consists of several elements:

Menu bar: The Nautilus menu bar has File, Edit, View, Bookmarks, and Help menus. 

The View menu offers options for controlling the way files are displayed in the Nautilus 

window, as well as the look and feel of Nautilus itself. The Edit menu lets you manu-

ally cut, copy, and paste files. The Go menu lets you quickly jump to other locations 

in the file system. Using the Bookmarks menu options, you can create web browser–

like shortcuts to certain locations in your file system, so you can access them instantly. 

There are also some ready-made bookmarks for folders in your /home directory: 

Documents, Music, Pictures, and Videos.

Toolbar: As in a web browser, the toolbar allows you to quickly move backward and 

forward from place to place in your browsing history. In addition, you can reload the 

file listing, in order to reflect any changes that might have taken place since the Nautilus 

window opened, and quickly navigate to popular file system locations, such as your 

/home directory.

Location bar: This feature, located beneath the toolbar, is unique to Nautilus and 

works in two modes. The first mode, which we’ll call button mode, is activated by 

default. This shows individual directories as buttons on the location bar and lets you 

see where you are in your file system at a glance, as well as quickly and easily move 

through your file-browsing history. For example, if you start in /home/keir (displayed 

as the keir button), and then browse to /home/keir/Pictures/holiday/disneyworld, 

clicking the Pictures button will return you to /home/keir/Pictures. The other folders 

listed on the location bar (holiday and disneyworld in this example) won’t disappear 

and will still have buttons, so you can return to those as well. It’s best demonstrated 

by example, so give it a try! The second mode, activated by clicking the icon to the left 

of the location bar buttons, switches the location bar into a more traditional, text-based 

bar, where you can type paths and filenames manually. To switch back to button 

mode, click the icon again. 

Zoom controls: To the right of the location bar are the zoom controls. These make the 

icons representing the files bigger or smaller. When you’re browsing a lot of files at 

once, shrinking them will fit more in the window. On the other hand, when you’re 

viewing photo thumbnails, it can be handy to increase the zoom setting, so you can 

see more detail in the pictures.
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View As Icons/List: To the right of the zoom controls is a drop-down list that switches 

between icon and list view. List view shows details about the files, such as file size, the 

type of file, its permissions, and so on. Icon view presents the files as a series of large 

icons. In many cases, the icons will give a clue as to the nature of the file; for example, 

audio files appear with musical note graphics. If the folder you’re browsing contains 

image files (or certain document files, such as PDFs), these will be automatically 

thumbnailed—the icon will be a small version of the contents of the file, as shown in 

Figure 12-4. This is very handy when browsing pictures for printing or editing.

Figure 12-4. Whenever you view a folder full of pictures in icon view, they will be automati-

cally thumbnailed.
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Places pane: The Places pane on the left lists the most popular locations within the 

file system, as well as any locations that you’ve bookmarked. Double-clicking each 

icon takes you to that location instantly. Clicking the File System entry takes you to 

the root of the file system (/). There are also bookmarks for your floppy drive (if you 

have one), your deleted files in the Trash folder, and any servers available on the local 

network.

■Tip  To bookmark a location, drag a folder to the blank area beneath the currently bookmarked folders in 

the Places pane.

As under Windows, you can right-click each file in the file browser window to see a 

context menu with options to rename the file, delete it, open it with particular applica-

tions, and so on. The Properties option on the context menu lets you view information 

about the file and alter certain aspects of it, such as its access permissions (discussed in 

Chapter 14). You can even add some text notes about the file if you wish!

■Caution  You should never delete your /home folder. Doing so will most likely destroy your personal 

Ubuntu configuration and prevent you from logging in, since many personal system and program settings are 

also stored in your /home folder.

Searching for Files

Nautilus includes a simple search tool. Click the Search button on the toolbar, and you 

will see a text box below the toolbar. In this text box, type any part of the filename you 

want to find. For example, typing festival will return any filenames with festival in them. 

By clicking the plus sign icon next to the Reload button after a search, you can specify 

an exact file type. To do this, click the Location drop-down list, and select File Type. Then 

click the Any drop-down list, and select the particular file type you want to find. For example, 

suppose you’re searching for a picture taken at a festival, and you know the filename contains 

the word festival. You also have various documents you created related to attending the 

festival, and their filenames also contain the word festival. In this case, to find only photo 

files, you can select Picture from the drop-down list, as shown in Figure 12-5. 
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■Note  The simple search tool in Nautilus is not as powerful as the Search for Files option, available from 

the Places menu.

Figure 12-5. The Nautilus search function lets you filter by file type. 

File and Folder Icons

Files and folders can have emblems assigned to them. These are smaller icons that are 

“tagged on” to the larger icons in both list view and icon view. Emblems are designed to 

give you quick clues about the nature of the file. To apply an emblem, right-click the file 

or folder, select Properties, and then click the Emblems tab. As shown in Figure 12-6, a 

range of icons is available; in fact, any file or folder can have several emblems applied at 

once. Simply put a check in the box beside the icons you wish to apply. Pick the ones that 

are meaningful to you. For example, a “cvs-conflict” emblem will probably be of interest 

only to programmers.
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Nautilus makes use of a handful of emblem icons for its own needs, too. For example, 

a square with an X in it indicates that you don’t have permissions to access that file or 

folder at all—not even to view it. In most cases, the file system emblems are self-explanatory.

■Tip  Want to have some fun with desktop icons? Right-click them, and select Stretch Icon. Then click and 

drag the handles at one of the corners. To restore an icon to its original size, right-click it, and select Restore 

Icon’s Original Size. 

Figure 12-6. A variety of miniature emblems can be applied to an icon to aid recognition of 

the file.

Special Nautilus Windows

As well as letting you view your files, Nautilus has a number of object modes. This is a 

complicated way of saying that Nautilus lets you view things other than files. 

The most obvious example of this is the Computer view of your file system, which 

presents an eagle’s eye view of your storage devices. To access this view, click Places ➤ 

Computer. If you have a card reader attached, it will appear here, as will any Windows 

partitions that may be on your hard disk. Double-clicking each item opens a standard 
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Nautilus file browser window (for this to work with Windows partitions, they must be set 

up correctly, as described in the “Accessing Windows Files” section later in this chapter).

 Another Nautilus object mode is the Fonts view, which lets you see at a glance any 

fonts installed on your computer. To access the Fonts view, click Go ➤ Location in any 

open Nautilus window, and then type fonts://.

Object mode comes into its own when viewing network locations. Clicking Places ➤ 

Network Servers brings up the browsing network object view, for example, which is a little 

like Network Neighborhood or My Network Places under Windows. You can also browse 

to FTP sites by clicking Go ➤ Location in a file browser window and entering an FTP address 

(prefacing it with ftp://).

■Note  You might be used to dragging and dropping files onto program windows or taskbar buttons within 

Windows in order to open the file. This works with only some programs within Ubuntu. Generally, the best 

policy is to try it and see what happens. If the program starts but your file isn’t opened, it obviously didn’t work.

HIDDEN FILES AND DIRECTORIES

When you view your /home directory via Nautilus, you’re not seeing every file that’s there. Several 

hidden files and directories relating to your system configuration also exist. You can take a look at them 

by clicking View ➤ Show Hidden Files in the Nautilus menu. Clicking this option again will hide the files 

and directories.

You might notice something curious about the hidden items: they all have a period before their file-

names. In fact, this is all that’s needed to hide any file or directory: simply place a period at the front of 

the filename. There’s no magic involved above and beyond this.

For example, to hide the file partypicture.jpg, you could simply right-click it and rename it 

.partypicture.jpg. You’ll need to click the Reload button on the toolbar for the file view to be 

updated and for the file to disappear. As you might expect, removing the period will unhide the file. 

Files are usually hidden for a reason, and it’s no coincidence that most of the hidden files are system 

files. In addition, every program that you install, or installed by default, will usually create its own hidden 

folder for its system configuration data. Deleting such files by accident will usually result in losing your 

personal settings for that particular program.

Launching Files and Running Programs
As with Windows or Mac OS X, most of the programs on your Ubuntu system automati-

cally associate themselves with various file types that they understand. For example, 

double-clicking a picture will automatically open the Eye of GNOME image viewer appli-

cation, and double-clicking a .doc file will start OpenOffice.org Writer.
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Ubuntu is automatically set up to view common file types. Table 12-1 shows which 

programs are required for viewing certain types of documents.

■Note  Whenever you install new software from the installation CD or the official software repositories, it 

should add an entry to the Applications menu. If for some reason this doesn’t happen, you can create a shortcut 

using the techniques explained in Chapter 10. 

1 Evince, File Roller, and Eye of GNOME are not present on the Applications menu. If you wish, you can add your own 
shortcuts for these applications by following the instructions in Chapter 10.

2 Playback of many media files is only possible after extra software is installed. See Chapters 18 and 19 for more 
information.

If you want to temporarily open a file type with a different program, right-click the file, 

select Open with Other Application, and choose the other program. From that point on, 

every time you right-click, you’ll be offered the choice of that program to open the file.

To make Nautilus automatically and permanently use the application to open the file 

type, right-click it and select Properties, and then click the Open With tab. Click the Add 

button to locate the application you wish to use if it’s not in the list. Finally, ensure the 

radio button alongside the program you wish to use is highlighted (you may need to click 

twice for this to happen), as shown in Figure 12-7, and then click the Close button. 

Table 12-1. Common File Types 

File Type File Extension Viewer Location on 
Applications Menu

Word processor 
document

.doc, .rtf OpenOffice.org Writer Office ➤ OpenOffice.org Word 
Processor

Spreadsheet .xls OpenOffice.org Calc Office ➤ OpenOffice.org 
Spreadsheet

Presentation .ppt OpenOffice.org Impress Office ➤ OpenOffice.org 
Presentation

PDF file .pdf Evince Not on Applications menu1

Compressed file .zip, .tar, .gz, .
bz2, and others

File Roller Not on Applications menu1

Image file .jpg, .gif, .bmp, 
and others

Eye of GNOME Not on Applications menu1

HTML file .htm, .html Firefox Internet ➤ Firefox Web 
Browser

Text file .txt, .log Gedit Accessories ➤ Text Editor

Audio file .wav, .mp3, .ogg2 Rhythmbox Sound & Video ➤ Rhythmbox 

Music Player
Video file

.mpg, .mpeg, .avi2 Totem Sound & Video ➤ Movie Player
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■Note  Under Windows, you can use Windows Explorer to launch program executables by just browsing to 

their locations within Program Files and double-clicking their .exe files. It’s technically possible to run programs by 

browsing to their locations using Nautilus, but this is discouraged. One reason is that Ubuntu doesn’t store all 

of its programs in one central folder, as does Windows. However, most programs that are used on a daily 

basis can be found in /usr/bin. If the program itself isn’t stored in /usr/bin, it will contain a symbolic link 

(effectively, a shortcut) to the program’s genuine location on the hard disk.

Figure 12-7. You can change which program opens a file by right-clicking, selecting Properties, 

and clicking the Open With tab.

Accessing Windows Files
Running Ubuntu on your PC makes you a relative stranger in a world of Windows users. 

It’s likely that you’ll need to access Windows files on a regular basis. If you’ve chosen to 

dual-boot with Windows, you might want to grab files from the Windows partition on 

your own hard disk. If your PC is part of a network, you might want to access files on a 

Windows-based server or workstation on which a shared folder has been created.
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■Note  Accessing shared printers attached to Windows computers is explained in Chapter 8, in the “Configuring 

a Windows/SMB Shared Printer” section.

Working with Files in Windows Partitions

If you’ve chosen to dual-boot Ubuntu with Windows on the same hard disk, Ubuntu will 

attempt to make your Windows partitions available automatically. 

■Note  It’s possible for an installation of Windows 2000 or XP to use FAT32 instead of NTFS, but this 

requires the user to make a deliberate choice during setup. Unless you know your Windows 2000 or XP 

system has been formatted with FAT32, it’s very likely that it is NTFS.

If the drive has automatically been made available, an icon for it should appear on the 

desktop. Double-clicking this should show your Windows partition contents. On a test 

system, the icon was identified by its partition designation, hda1. 

If you find that your Windows partition isn’t visible, you can follow these instructions 

to make it visible. This involves mounting the Windows partition under your Ubuntu file 

system. Mounting is explained in more detail in Chapter 14.

1. These instructions need to be carried out at the command prompt, so start by 

opening a GNOME Terminal Window: click Applications ➤ Accessories ➤ Terminal. 

2. You need to identify the Unique Udev ID (UUID) number of your Windows partition. 

This is simply the hexadecimal number that Ubuntu uses to identify the drive inter-

nally. If your computer is relatively new, it probably has an SATA hard disk, so type 

the following at the command prompt:

sudo vol_id –u /dev/sda1

If you’re using an IDE (PATA) hard disk, type the following to determine the UUID 

number:

sudo vol_id –u /dev/hda1

These instructions assume that the Windows partition is the first on the hard disk, 

which will be the case for most users. If you know the Windows partition is the 

second partition, replace /dev/sda1 or /dev/hda1 with /dev/sda2 or /dev/hda2. 

3. You’ll be prompted to enter your password; do so.



CH AP T E R  1 2  ■  M A N A G IN G  Y O U R  F I L E S 293

4. Make a note of the output of the command. On our test PC, the line read 

6284101A840FEEFB, but yours will almost certainly be different. 

5. Now you need to create a mount point. This is a dummy folder that’s used to make 

the contents of the Windows partition magically available. The Ubuntu convention 

is to create a directory within the /media directory, as follows:

sudo mkdir /media/Windows

6. You need to edit the /etc/fstab file. This is the configuration file that tells Ubuntu 

where to find all of the file systems it uses. This includes the root file system, without 

which Ubuntu can’t operate, so you should take extra care when editing this file. To 

load the file into the Gedit text editor, type the following:

gksu gedit /etc/fstab

7. The file looks complicated, but don’t worry. Simply scroll to the bottom and press 

Enter to create a new line. Then type the following:

UUID=<UUID>  /media/Windows  ntfs  defaults,nls=utf8,umask=007,gid=46  0  0

Replace <UUID> with the hexadecimal number you noted earlier. For example, on 

our test PC, the line within fstab read as follows (see also Figure 12-8):

UUID=6284101A840FEEFB  /media/Windows  ntfs  defaults,nls=utf8, ➥

umask=007,gid=46  0  0

8. Click File ➤ Save within Gedit to save your changes. 

From now on, the Windows file system will be made available automatically whenever 

you boot, and it should appear as an icon both on the desktop and within the Computer 

view of Nautilus (click Places ➤ Computer to see it). However, you can mount it immedi-

ately by typing the following command at the prompt:

sudo mount /media/Windows

■Note  You can write to or edit files in an NTFS partition. However, be aware that you could easily destroy 

your Windows partition because on Ubuntu, all Windows files (even the system-critical files) can be over-

written without warning. On the positive side, this feature allows you to easily recover your files from Windows 

if it has crashed. 
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Figure 12-8. By editing the /etc/fstab file, you can make your Windows partition available 

under Ubuntu.

Accessing Networked Files

The easiest way to access shared folders on Windows workstations or servers over a 

network is to click Places ➤ Network. This will start Nautilus and attempt to search for 

Windows machines on your local network, just like with Network Neighborhood and My 

Network Places on the various versions of Windows.

■Tip  When using this method, if the icon for a computer or workgroup is a blank sheet of paper, click the 

Refresh button on the toolbar. The icon should then change to a computer. In our tests, we found that we 

couldn’t access the network resource if the icon wasn’t set correctly. 

If you’ve ever used the network browsing services under Windows, you might already 

know how unreliable they can be—some computers simply don’t appear in the list, others 

appear eventually after a wait, and others appear but then prove to be mysteriously 

inaccessible.
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A far quicker and more reliable method of accessing a Windows shared folder is to 

manually specify its network name or IP address. The network name is simply the name 

of the computer that’s used during networking. The IP address is the computer’s identifying 

number and usually takes the form of four octets separated by periods, like this: 192.168.1.4. 

You should try using the network name first when connecting to a computer. If that 

proves unreliable, try using the IP address instead. You can discover the network name 

and IP address as follows:

Network name: You can discover the network name of a Windows Vista computer by 

clicking Start and right-clicking Network on the menu. Click Properties on the menu, 

and in the window that appears, look at the name of This Computer on the diagram 

beneath the Network and Sharing Center heading. For example, the name of our test 

PC is keir-pc. To discover the network name within Windows XP, right-click My 

Computer, select Properties, and then click the Computer Name tab in the window 

that appears. Look under the Full Computer Name heading. 

IP address: To find out the IP address, open an MS-DOS command prompt. To do this 

under Windows XP, click Start ➤ Run, and type cmd. Under Windows Vista, click the 

Start button and type cmd into the Start Search text box. Under both XP and Vista, type 

ipconfig at the prompt. Then, under XP, look for the line that reads “IP Address” and 

note the details. Under Windows Vista, look for the line that reads “IPv4 Address” and 

note the number (on our test computer, we had to scroll up the window to see the line). 

To access a shared folder, open a Nautilus file browser window (Places ➤ Home), and 

then click Go ➤ Location. In the box, type the following:

 smb://computer name/

Alternatively, if you wish to use the IP address, type the following:

smb://IP address/

Obviously, in both cases, you should replace computer name and IP address with the 

details you noted earlier. 

You may also be prompted to enter a username and/or password to access the shared 

folder, as shown in Figure 12-9. 

■Note  If you’re accessing a Windows 95, 98, or Me shared folder, only password protection will have been 

set (these versions of Windows are unable to specify a username). However, when prompted by Nautilus, you 

still need to type something into the Username box to gain access—anything will do, as long as the password 

is correct. You cannot leave the Username box blank.
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Figure 12-9. If the shared folder requires a username and/or password, you’ll be invited to 

enter these. 

To create a permanent desktop shortcut to the Windows folder, right-click a blank spot 

on the desktop and create a launcher. In the Command text box, enter nautilus, followed 

by the full network path to the share. You can discover this by browsing to the shared 

directory using Nautilus, as described previously, and then clicking the icon next to the 

location bar to switch to the text-mode view of the path. Then cut and paste the text into 

the Command box.

For example, on our Ubuntu setup, we created a shortcut to the Pictures directory on 

the computer keir-office-pc by typing the following into the Command box:

nautilus smb://keir-office-pc/pictures

For more information about creating desktop launchers, see Chapter 10. 

When using the launcher after rebooting your Ubuntu system, you might notice the 

folder takes a few seconds to appear. This is normal and merely the result of the time 

Ubuntu takes to log on to the computer sharing the files.
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Sharing a Folder from Within Ubuntu

As well as accessing the shared files of other Windows users, you can also set up your own 

shared folder under Ubuntu for Windows users to access (or, indeed, other Ubuntu 

computers). To do this, follow these instructions:

1. Right-click the folder you wish to share, and select Sharing Options from the menu. 

2. In the dialog box that appears, put a check in the Share This Folder checkbox. If this 

is the first time you’ve shared a folder, a dialog box will appear telling you the 

sharing service software is not installed. Click the Install Service button to add it.

3. You’ll be prompted to type your password because some additional software needs 

to be installed. Following this, Ubuntu will automatically download and install the 

Samba file-sharing components. 

4. Once the installation has finished, cancel the Folder Sharing dialog box and log out 

of the computer (click System ➤ Quit ➤ Log Out). This performs some necessary 

background configuration. Then log back in again.

5. Right-click the folder you want to share again, and select Sharing Options again. 

Then put a check in Share This Folder again.

6. In the Share Name text box, type a name by which the share will be identified by 

other computers on the network. At the bottom of the dialog box you might see 

some warning messages. However, we found some of these were wrong or simply 

didn’t make sense. This is obviously a bug, and our advice is to ignore them. If you 

genuinely do something wrong, like type too long a share name, Ubuntu will tell 

you later on.

7. By checking Allow Other People to Write in This Folder, the shared folder will be 

made writeable, rather than read only. 

■Caution  Do not check the Guest Access box! At the time of writing, Ubuntu has a bug whereby allowing 

guest access (access without a username or password) results in files without ownership and with no read/

write permissions for anybody. Effectively, any files placed in the folder will be unreadable by you unless you 

manually alter their permissions and ownership. This is described in Chapter 29, but is a long and annoying 

process to have to go through for each file placed in the shared folder. 

8. Click the Create Share button. A dialog box might appear saying that the permis-

sions of the folder you wish to share need to be changed. Agree to this by clicking 

the Add the Permissions Automatically button.
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Following this, Windows users can access the shared folder using My Network Places/

Network Neighborhood, where it should be “detected” alongside other Windows computers 

(under Vista, click Start ➤ Network). Users will be able to log in with your Ubuntu user-

name and password. 

■Note  To access the shared folder from another Ubuntu computer, you might need to specify its IP address. 

To find out the IP address, open a GNOME Terminal window (Applications ➤ Accessories ➤ Terminal) and 

type ifconfig. Then look for the numbers alongside the inet addr entry. 

Accessing Removable Storage Devices
Ubuntu automatically makes available any CDs or DVDs you insert into your computer, 

and they’ll appear instantly as icons on the desktop. The same is true of any card readers 

or USB memory devices that you use. Alternatively, you can access the storage devices by 

clicking Places ➤ Computer. 

Working in the Computer Window

In the Places ➤ Computer window, you’ll find icons for all of the storage devices attached 

to your computer, including the floppy disk drive, as shown in Figure 12-10. However, 

because of the way floppy disk drives work, Ubuntu isn’t able to automatically detect if a 

floppy has been inserted. Instead, you’ll need to double-click the icon, as with Windows.

■Note  In days of old, special tools were used to access MS-DOS floppies under Linux, and you might hear 

some Linux old-hands talking about them. Nowadays, you can simply use Nautilus without needing to take 

any special steps.

Whenever you double-click any entry in the Computer window, it will open a Nautilus 

file browser window. You can copy files by clicking and dragging, and right-clicking files 

offers virtually all the options you could need.

■Tip  You don’t need to use Places ➤ Computer each time to access your floppy, CD, or DVD drive. These drives 

are mounted in the /media folder on your hard disk. Just browse to /media/floppy, and /media/cdrom. 
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Figure 12-10. Select Places ➤ Computer to access your removable storage drives.

Ejecting Media

Ubuntu isn’t quite like Windows when it comes to ejecting or unplugging removable 

storage devices. In some cases, devices must be unmounted, which is to say that you need 

to tell Ubuntu that you’re finished with the device in question and that you’re about to 

unplug it.

In the case of CD or DVD discs, you can simply press the Eject button on the drive itself. 

Ubuntu is able to detect that the disc is being ejected, so it will automatically unmount the 

drive. If the disc ever refuses to eject, right-click its icon on the desktop or within Computer 

and select Eject. 

In the case of floppy disks, USB memory sticks, and other USB storage devices, you 

should always right-click the icon and select Unmount Volume. Then you can unplug or 

remove the device. This also applies when you’re removing a memory card from a card 

reader—before pulling out the card from the reader, it needs to be unmounted. 

■Note  It’s necessary to close any files that were open on the device before unmounting, and even close 

any file browser windows that were accessing the device. 
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If you fail to unmount the device, Ubuntu will still believe the device is attached. This 

shouldn’t cause too many problems, but it could crash any programs that were accessing 

the device. It might also mean the card isn’t recognized properly when you reinsert it. In 

rare instances, data loss can occur. 

Summary
This chapter has led you on your first steps in exploring the Linux file system. The file 

system is vitally important to how Linux works, and we’ll go into it in much depth in 

upcoming chapters.

Here, you were introduced to elementary concepts, such as where personal files are 

stored and the basic rules that govern what you can and cannot do with files. We also 

looked at the principal method of accessing files via the GUI: the Nautilus file manager. 

Additionally, you learned how to run programs manually, as well as how to access any 

Windows partition or files that may exist on your hard disk or across a network.

In Part 4 of this book, starting in the next chapter, we will look at some of the underlying 

technology that makes Ubuntu work, and how you can gain more control over your 

computer. Chapter 13 introduces the BASH shell—perhaps the most powerful piece of 

software offered by Ubuntu to control your system.


